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Digital Portfolios Made Easy 
 

Introduction 

Digital Portfolios Made Easy (DPME) is a portfolio system developed to provide a 
set of templates for presenting digital portfolios that are complete yet simple. 
 
The growing interest in electronic and digital portfolios has created opportunities for 
practitioners to present portfolios that are more rich and interconnected than the 
traditional notebook professional portfolio. The greatest obstacle to creating digital 
portfolios, however, can be the practitioner's perception of the technology itself. 
The technology does not need to be overly complicated, and the goal of DPME is 
to make the process as transparent and intuitive as possible. The DPME templates 
provide a framework within which to build a standards-based, individualized 
professional portfolio. The DPME templates are provided in three formats: Word, 
HTML, and xWord. These three formats allow practitioners of all skill levels to use 
software that most already have on their computers.  
 
Creating your own digital portfolio can seem like a difficult task. The toughest part 
of creating any portfolio is selecting the artifacts that you want to include. It is 
difficult to decide how you can best portray your professional self through a 
collection of artifacts that you have created and accumulated over time. Once you 
have identified your collection of artifacts, you need a format to organize and 
present your materials. The DPME templates can aid in the development of your 
digital portfolio by providing an intuitive framework that emphasizes the artifacts 
and their meaning to your professional development. 
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Overview 

DPME templates integrate two forms of portfolio organization, standards-
indexed™ and standards-referenced™. These concepts are unique to DPME. 
Standards-indexed™ portfolios typically align artifacts to standards in a linear 
manner. A single artifact frequently aligns with only one standard. This system 
makes it easy for evaluators to assess the depth of fulfillment for each standard, 
and the emphasis is on the standards rather than the educator’s actual artifacts.  

Standards-referenced™ portfolios use artifacts as the central element of the 
organizational system, which consequently emphasizes reflection. The portfolios 
are presented and subsequently linked to all relevant standards. The DPME 
format encompasses both standards-indexed™ and standards-referenced™ 
forms of organization. Any form of organization, however, is not complete without 
reflection. DPME provides prompts where teachers describe, analyze, and plan 
based upon artifacts and the experiences associated with them (Bullock & Hawk, 
2001). Reflections provide background information and context of the artifact, 
describe what the teacher learned, provide insight into teacher candidate thinking, 
and encourage future planning based upon experience (Bullock & Hawk, 2001).
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xWord Template 

The DPME xWord template is a portfolio template that uses two Microsoft Office 
applications. This template contains two files: a Microsoft Word file and a 
Microsoft Excel file. The unique features of this template format include “auto-fill,” 
which removes the repetitive tasks of copying and pasting artifact names 
throughout the template, and this template format allows for the possibility of 
aligning artifacts to multiple sets of standards. The Word file is a single document 
that ranges from 23-30 pages. The Excel file is a single worksheet that ranges 
from 5-20 tabs. The lengths of both of these files depend on the number artifacts a 
practitioner uses and the types of standards being addressed. Previously created 
hyperlinks/bookmarks allows for easy navigation between files.  

Organization 

The Word file contains approximately 25 pages: Opening Page, Standards 
Overview, and Artifact Pages. The first page is the Opening Page, which is where 
a practitioner outlines his or her educational philosophy and/or a welcome 
statement. Following the Opening Page is a Standards Overview Page that 
contains general definitions for the standards being addressed in a given portfolio. 
This page also serves as a navigation menu to view individual Standard Pages. It 
is also possible to have more than one Standards Overview Page depending on 
the amount of standard types. Approximately 20 Artifact Pages follow the 
Standards Overview Pages. Artifact pages can be directly accessed in this file by 
scrolling down, or these pages can be reached from the Artifact Matrix where 
standard/component alignment information is displayed. 

The Excel file contains approximately 8 pages: Artifact Matrix and Standard 
Pages. The first page is the Artifact Matrix Page, which is the navigational hub of 
all DPME templates. The Artifact Matrix page also serves as a target for 
numerous functions that are placed on individual Standard Pages contained in the 
Excel file. Standard Pages take information from the matrix and copy it throughout 
the template. This copying can happen for one set of standards or multiple sets of 
standards without requiring repetitive typing or copying and pasting. No 
information will have to be entered on to Individual Standard pages. An excel 
function copies artifact names from the artifact matrix when an “x” is typed into an 
artifact’s row. 

Microsoft Word Template 

The DPME Word template is a portfolio template that uses software familiar to 
most practitioners. After extensive testing, the Word format has been refined to 
meet the needs of various practitioner skill levels. This single document may 
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range from 25-50 pages in length depending upon the standards being addressed 
and the number of artifacts being used. Internal hyperlinks within the document 
provide easy navigation between artifacts, standards and reflections. 

Organization 

After extensive testing and retesting, the pages in a DPME Word format were 
combined into a single Word document. This document may range from 20-50 
pages in length depending upon the standards being addressed and the number 
of artifacts being used. It opens with the Opening Page that includes a photo of 
the portfolio creator and an educational philosophy. The next page provides a 
Standards Overview, which is followed by the Artifact Matrix that acts as the major 
navigational tool for the portfolio. The individual Standard Pages follow in 
succession. Finally, the Artifact pages are placed at the end of the document. The 
template is designed to accommodate 15 artifacts. This number of artifacts can 
either be lengthened or shortened depending upon a practitioner's needs. 

Navigation 

Combining all of these pages into a single document was done to increase the 
efficiency and speed of navigation throughout the materials. The extended length 
of this document does not mean that the reader has to scroll through all of these 
pages in a sequential order. 

Microsoft Word incorporates navigational capabilities called Hyperlinks and 
Bookmarks. Hyperlinks allow a user to create links to other locations within the 
portfolio document, to other files, or even to websites. Most links are already 
provided in the template. You will find that clicking on blue underlined numbers or 
words will cause you to move to other places in the document. 

Hyperlinks are included in the template through the Standards Overview Page and 
Artifact Matrix. Also, a navigation bar is located at the bottom of every page. It 
allows movement between three main pages: Opening Page, Standards Overview 
and Artifact Matrix. 

HTML Template 

The DPME HTML template is for more technologically advanced practitioners who 
want to post their portfolios on a website. The DPME HTML template contains the 
same prompts and look and feel of the Microsoft Word template. Unlike the Word 
format, the parts of the portfolio are contained in separate files. Hyperlinks are 
provided on the Standards Overview and Artifact Matrix pages to enable simple 
navigation between files. Also, a navigation bar is provided that connects to the 
pages: Opening Page, Standards Overview, and Artifact Matrix. 
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DPME Process Overview: 
• Developing Background Skills 

o File Management 
o Digital Imaging and Scanning  
o Creating Hyperlinks in Microsoft Word  

• Creating an Opening Page 
• Creating an Artifact Matrix 
• Creating Artifact Pages and Writing Reflections 
• Creating Individual Standards Pages 

 
File Management 

An important background skill to posses when creating digital portfolios is being able to 
organize and manage files. What follows is a step-by-step process, beginning with 
downloading a template format, for managing the many files that support a digital 
portfolio. Two general principles apply to file management: (1) the location of files in 
relation to their folder(s) is set and cannot be changed; (2) before new objects, e.g., 
images, are placed on a page or new files are linked to, they must be placed in the 
storage folder. 
  
After Downloading a Template Format: 

• On the desktop, ‘unzip’ the newly downloaded folder by right-clicking on folder 
icon and selecting "Extract All..."  

o Follow steps described in Wizard window  
o Two folders should appear on your desktop, one with a zipper and another 

without  
• Rename the folder without the zipper, 'your last name_portfolio', e.g., 

‘smith_portfolio’  
• You can now delete the folder not named 'smith_portfolio'  
• Start the necessary software program, either Microsoft Word or an HTML editor  
• Use the File menu to navigate to your folder on the desktop and select the file 

you want to open, e.g., 'index.html' 
 
During the Session: 

• Save (not Save As) at least every 5 minutes 
 
End of the Session: 

• Save (not Save As) your file  
• File > Exit/Quit the software program  
• Insert your USB Flash drive or other storage device  
• Drag the FOLDER, not just individual files, from the desktop to your USB Flash 

drive or other storage device folder  
• Drag your original folder located on the desktop to the trash/recycle bin or to the 

My Documents folder on the computer (This will ensure that the most recent 
portfolio is at the very least on your storage device)  
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Editing a Continuing Project 
 
Beginning of the Session: 
• Insert your USB Flash drive or other 

storage device  
• Drag your FOLDER from the USB Flash 

drive or other storage device to the desktop  
• Eject your USB Flash drive or other 

storage device (This is to ensure that you 
are working on the folder off of the Desktop 
and not your storage device)  

• Start the software program used for the 
current project  

• Use the File menu to Open your project  
• In the resulting window, navigate to your folder on the desktop and select the file you 

want to open  
 
During the Session: 
• Save (not Save As) at least every 5 minutes  
 
End of the Session: 
• Save (not Save As) your file  
• File > Exit/Quit the software program  
• Insert your USB Flash drive or other storage device  
• Drag the FOLDER, not just individual files, from the desktop to your USB Flash drive 

or other storage device folder  
• Drag your original folder located on the desktop to the trash/recycle bin or to the My 

Documents folder on the computer (This will ensure that the most recent portfolio is 
at the very least on your storage device)  
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Digital Imaging and Scanning  

After artifacts have been collected, if not already digital, they need to be put into formats 
that will display well in a digital portfolio. The recommended formats include (.pdf) (.jpg) 
(.gif). There are numerous ways of transforming a previously non-digital artifact into one 
these file formats. The linked handout describes background information that may be 
helpful in transforming artifacts. 

Creating Hyperlinks in Microsoft Word  

IMPORTANT: All linking must be preceded by dragging or placing files into storage 
folder. 
 
Linking to a File: 
• Highlight a word that you want to serve as the link (That which is clicked to 'go' to 

another file)  
• Go to the Insert menu  
• Select Hyperlink  
• In the left column select Existing Webpage or File  
• Navigate to portfolio folder  
• Select the desired file within Storage folder  
• Select OK  
 
Linking to a Webpage: 
• Highlight a word that you want to serve as the link (That which is clicked to 'go' to 

another file)  
• Go to the Insert menu  
• Select Hyperlink  
• In the left column select Existing Webpage or File  
• In the Address dialog type desired URL address, including http://, or Copy and 

Paste URL address from web browser  
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DPME Template: Opening Page  

Location of pages by template versions: 

xWord portfolio.doc: page 1 

Word single_document.doc: page 1 

HTML index.html 
 
The Opening Page involves inserting 
an image of oneself on the page and 
crafting and introductory statement 
and/or educational philosophy. 

Inserting an Image: 

• Place cursor in table cell 
• Delete text (Place Picture 

Here) 
• Go to Insert menu 
• Select Picture 
• Select From File 
• Navigate to portfolio folder 
• Select storage 
• Select desired image 
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DPME Template: Artifact Matrix 

Location of pages by template versions: 

xWord matrix.xls: matrix tab 

Word single_document.doc: page 3 

HTML admin folder > matrix.html 

The Artifact Matrix provides a standards-indexed™ and -referenced™ view of how 
artifacts apply to standards and their criteria/components. This matrix is a quick-view of 
standards and artifacts alignment as well as the navigational hub of DPME templates. 
Under the column labeled Link are previously created links to Artifact Pages. Under 
the columns labeled Standards are previously created links to individual Standards 
Pages. 

Creating xWord Artifact Matrix: 

• Put the names of relevant artifacts in the 
column Artifact Name 

• Identify the pertinent standards and 
components/elements that align with an artifact 

• Each row is a standard component 
• Mark an "x" in each column  

  

Creating the Artifact Matrix (Word 
and HTML): 

• Put the names of relevant artifacts in the 
column Artifact Name 

• Identify the pertinent standards and 
components/elements that aligns with an 
artifact 

• Signify this alignment with the 
criteria/component's letter or number in the 
appropriate standard's column 
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DPME Template: Artifact Pages 

Location of pages by template versions: 

xWord portfolio.doc: pages 3-22 

Word single_document.doc: pages 
12-26 

HTML admin folder > artifacts folder > 
artifact.html 

 
These templates are designed to 
provide a space for reflections that 
include a description, analysis and 
future plans for each artifact. 
Connections to the specific criteria for 
each pertinent standard are explained 
here as well. Finally, the artifact is 
either included in the document or a 
link is provided to access the artifact. 
These pages contain three basic 
parts: Reflection, Standards/Criteria 
Connections, and the display of or 
link to a digital artifact. 

Creating Artifact Pages and Writing Reflections: 

• Title: Begin by placing the title of the artifact in the title, ex. Artifact 1: Math 
Lesson Plan. 

• Reflection: Write a reflection about the artifact. The recommended format is 
What? So What? and Now What? This format can also be thought of as Describe, 
Analyze and Plan. Reflections are typically three paragraphs in length. The first 
paragraph is where you describe the artifact. You analyze the artifact in the 
second paragraph. This analysis might include descriptions of the success of a 
lesson or the significance of an event. The third paragraph is where you explain 
what you learned from the experience and how it will impact future practice. 

• Standards/Criteria Connection: Explain how an artifact meets each of the criteria 
identified on the Artifact Matrix and Individual Standards Pages. Each 
explanation is prefaced with a number and letter representing the specific 
criteria/component (i.e., 1g, 3d, or 7c). 

• Artifact: Place an artifact on the page or create a link to the artifact. Insert a photo 
of the artifact the same way as on the Opening Page. Create a link to a digital 
artifact in the storage folder or to a website. 
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DPME Template: Standard Pages 

Location of pages by template versions: 

xWord matrix.xls: sta tabs 

Word single_document.doc: 4-11 

HTML admin folder > standards folder 
> standard.html 

Individual Standards Pages list the criteria/components for each standard. These pages 
are also another location that illustrates the alignment among artifacts and 
criteria/components. 

Creating xWord Standard Pages: 

• An Excel function copies information from the 
Artifact Matrix on to each of these pages. This 
function can be easily deleted. It is important to 
remember that if an artifact name does not 
appear, to check the Artifact Matrix and not to 
manually type in the artifact name, as this will 
delete the function.  

Creating Individual Standard Pages 
(word and HTML): 

• List the name of each artifact 
that aligns with a 
criteria/component in the 
Artifacts column 

• Repeat as necessary for each 
artifact 

• Once an artifact is entered in 
the Artifacts column, a link needs to be created from the artifact's name to its 
Artifact Page  

o Highlight the artifact's name 
o Go to the Insert menu 
o Select Hyperlink 
o In the left column, select Place in this Document 
o In the middle window, select the corresponding artifact's Bookmark, ex. 

A1 
o Select OK 




